PDA

View Full Version : antialiasing error



ng1223
12-09-2011, 06:38 AM
Hello
I have some inquiry about Anti-Aliasing of 2012 bunkspeed pro.
Attached are some errors I found after some tests.

1st problem)
48 49
Quality 10000 + Qualilty Level 8

50
But bad quality by the best antialiasing option



2nd problem)
'No Antialiasing' and Qualuty Level 8' make same pictures same quality.
51 > 50
52 > 50

somebody let me know please ...

JohnG
12-09-2011, 08:37 AM
The Anti Aliasing setting is for raster mode only, it has no effect on your final ray traced image.
The jagged edges are more likely because your resolution is so small, just 300 pixels and its a jpeg which can introduce artifacts.
Try rendering a higher resolution image and save it as a tiff.
Also you don't need 10000 passes for such a simple scene.

andy
12-09-2011, 04:30 PM
JohnG is correct.

Here's some explaination of what's happening in your case.
Your scene is overbright, meaning the white values are a value of more than 1.0/255. Antialiasing is an averaging of two values that happen within the same pixel, which is how it make a diagonal line appear smother. Imaging the white line of your box goes through the background at 25% and bisects it directly in the middle. If the line is only 255 white then the value ends up being about 160. But if the value is something like 500 (even though it displays as 255) then you have a problem when you average those. Average 500 and 62 (25% from black). 281, that's more than white. That means one pixel will end up displaying as white, and the next one over (the background alone) will be closer to 62. That's a big jump, so causes the stairstep.

Want to avoid that? Just don't have bright spots in your scene. Your top light is too bright. That's it. This goes for ANY render that doesn't allow clamping the color before sampling. And clamping the color essentially ruins your 32bit value if you need it. I think this Might be on the wishlist though. There's no reason Not to clamp a jpeg or 8bit tiff.
You can help this aliased edge by doing what JohnG suggests, just add resolution. That's one trick I've always used when a render isn't giving me enough control and rendering at twice the size ends up being faster than raising the antialiasing settings (usually because of textures). That is Rare though. You will continually get a smaller stairstep as you increase in resolution, but you are masking the problem, and not fixing it.

The way antialiasing works in Shot is it samples the Entire scene the same, and keeps adding more samples. As long as you don't have spots that are more than white, you won't get antialising issues. Just take a bit more care on how bright lights are and strike a balance with how reflective your objects are.
Unfortunately, you can't always do that, like in the case of chrome. You'll most likely end up at some point having a spot on the chrome that reflects your light, which is probably brighter than 1.0.


Oh, and one more thing (that I feel is wrong). The antialiasing is done over the environment even if you have it turned off.