+ Reply to Thread
Results 1 to 6 of 6

Thread: Selectabel Shadows

  1. #1
    Senior Member amoncur's Avatar
    Join Date
    Nov 2011
    Location
    Arizona
    Posts
    150

    Selectabel Shadows

    It would be awesome to be able to have a checkbox for individual parts or assemblies that allows you to choose whether or not they produce shadows. I very often have situations where I've set up planes in the environment with emissive materials assigned that end up casting unwanted shadows both on the ground as well as on the product I'm rendering. I always end up having to create an extra "object" pass and screen out the unwanted shadows. If we could simply choose to not allow these objects to cast shadows in the first place that would sure help streamline the workflow. Turning off shadows in the environment tab just eliminates shadows for everything, which is not what I want. I'd like to be able to selectively turn off shadows for individual parts/assemblies.

  2. #2
    Senior Member andy's Avatar
    Join Date
    Nov 2011
    Posts
    781
    I'm not sure you can do that with iray. Things don't really cast shadows in iray, they block light. With the beta you might try making the object 100% transparent, and also emissive. This didn't work before, but it may work in the new version. Use an IOR of 1.0 to also avoid any issues there, and no glossy values to keep calculations simple.

    Again, I'm not sure if that will work, but I think that's your best bet.

    For opaque objects, I think you're out of luck with not casting a shadow. Also, using that trick won't work if you hope to bounce light off of the object. If you make it reflective it will end up blocking some light as well.
    It's just something you have to deal with when working with a renderer based on an accurate model. Everything blocks a certain amount of light, even air.

  3. #3
    Senior Member amoncur's Avatar
    Join Date
    Nov 2011
    Location
    Arizona
    Posts
    150
    Thanks, Andy. David - will Andy's suggestion work in 2014? I know I've tried doing this in 2013 without success (the planes still create shadows).

  4. #4
    Administrator david.randle's Avatar
    Join Date
    Apr 2011
    Location
    San Diego, CA
    Posts
    1,252
    I havn't tried Andy's suggestion in the 2014 products yet but its worth a try. Andy is also correct about iray. in a physically correct renderer there is no such thing as having an object that doesn't cast a shadow. This may be something that the new Fast mode can be made to do over time however.
    David Randle / General Manager / Bunkspeed

  5. #5
    Senior Member andy's Avatar
    Join Date
    Nov 2011
    Posts
    781
    Well it's not Quite perfect, but it might get you what you want. I got it not to crash today so I thought I'd give it a quick go.

    First, your light, which you don't want to cause shadows, has to be a solid object.

    The material: Generic
    white transparency color
    white emission color
    zero roughness
    IOR of one

    Any other settings contribute very little, but feel free to experiment.

    My test was a plane for the floor with a matte white. I created a box, mostly flattened to a plane like a thick piece of glass.
    And one tiny plane to shed some light on the situation to see if the light plane blocked light.

    Issue 1: the generic material can not have emission values of more than 1. I'm not sure why Bunkspeed chose to do that, but you'll have to work with that limitation. That might mean rendering the entire scene Extremely dim, then adjusting it later. BIG pain.

    Issue 2: you still end up with just a little tiny bit of light being moved around inside the surface. You Shouldn't, but you do. If it's IOR is 1 then you should see right through the thing at 100% transparency. I'm sure David will bring this up with the iRay guys.

    Last thought: The object is completely visible using this method from the facing normal side. If you turn a solid mesh object completely inside out (not allowed in nurbs objects) would it end up being completely invisible? Either way you are stuck with a light limited to a value of 1. But it's a start.
    One trick I haven't tried also is using an HDR in the diffuse instead of emmisive. That works in some software.

    It's not my project, so that's all the time I have to share, but hopefully that's a start.

  6. #6
    Senior Member amoncur's Avatar
    Join Date
    Nov 2011
    Location
    Arizona
    Posts
    150
    Andy, I really appreciate you taking the time to do this - thank you! I will definitely try that out once I get 2014 installed.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts